Issues with broadcast sending
Incident Report for Drip
Resolved
We are happy to report all delayed broadcasts have been sent and we aren't seeing any further delays at this time. If you run into any further issues, please reach out to us at support@drip.com.
Posted Aug 15, 2019 - 11:36 CDT
Monitoring
A fix was deployed for this issue and we are seeing all new broadcasts delivered in a timely manner. Emails delayed from earlier have been delivered, but we are continuing to monitor this issue to keep our time to deliver broadcast emails down.
Posted Aug 15, 2019 - 10:48 CDT
Update
Our team is getting closer to deploying a fix for this issue that will improve the delays we are seeing with broadcast deliveries. In the meantime, we are continuing to see the delays in sending decrease. Thank you for your continued patience.
Posted Aug 15, 2019 - 10:25 CDT
Update
We're continuing to make progress on those broadcast sends but are still working through delays. Thanks for hanging in there with us today.
Posted Aug 15, 2019 - 10:01 CDT
Identified
We are processing broadcasts now with increased efficiency, but are still seeing delayed deliveries. Thank you for bearing with us as we continue to work through this issue.
Posted Aug 15, 2019 - 09:31 CDT
Update
We are continuing to investigate reports of delivery delays specific to broadcast emails. Thank you for sticking with us on this. We don't have further information to share yet, but this is the top priority for our team right now and we are taking action to resolve this issue.
Posted Aug 15, 2019 - 09:01 CDT
Investigating
We are experiencing reports of delays sending broadcast emails. This issue is not impacting automation, campaign, or confirmation emails. Our team is investigating and we will update as soon as we have more information.
Posted Aug 15, 2019 - 08:24 CDT
This incident affected: Email Sending.