Workflow delays
Incident Report for Drip
Resolved
Our team has successfully resolved the issue here. Our apologies for any inconvenience this caused and thanks so much for your patience. Please reach out to the Support team through the in-app widget or through email at support@drip.com if you have any questions or concerns.
Posted Dec 05, 2022 - 17:01 CST
Monitoring
A fix has been implemented and our team is monitoring the results. We will continue to provide updates here until the issue is fully resolved. Thank you for sticking with us.
Posted Dec 05, 2022 - 16:50 CST
Investigating
We are currently working to address delays in people processing through workflow triggers. We understand the inconvenience this can cause and we are actively working to address the issue. We'll provide an update here as soon as we have more information.
Posted Dec 05, 2022 - 16:21 CST
This incident affected: Workflows and Rules.