Delays in email sending
Incident Report for Drip
Resolved
We appreciate your patience while we worked to resolve these delays. Email sending has returned to its expected sending times. Thank you for sticking with us!
Posted Apr 16, 2020 - 11:10 CDT
Investigating
We are currently experiencing a delay in email sending. Our team is aware of the issue and working diligently to restore expected sending times. We apologize for any inconvenience this is causing and will provide an update here shortly.
Posted Apr 16, 2020 - 10:45 CDT
This incident affected: Email Sending.