Email Deliverability Impacted

Incident Report for Drip

Resolved

The incident related to email sending has been resolved.
Posted Feb 13, 2023 - 16:52 CST

Update

As we are continuing to work towards a resolution for the email delivery issue, we recommended that any emails which are time-sensitive be paused or unscheduled. While the issue is ongoing, any emails not coming from an account that utilizes a custom-sending domain will be held until the aforementioned issue is fully resolved.
Posted Feb 13, 2023 - 13:40 CST

Identified

The issue has been identified in relation to email sending and further investigation into the issue is ongoing.
Posted Feb 13, 2023 - 11:11 CST

Investigating

We are currently experiencing issues specific to our email processing and delivery. All other platform functionality should not be impacted. We apologize for the inconvenience this causes, we are currently investigating the root of the issue.
Posted Feb 13, 2023 - 09:46 CST
This incident affected: Email Sending.