Issues with Broadcast Emails
Incident Report for Drip
Resolved
We are happy to report all delayed broadcasts have been sent and we aren't seeing any further delays at this time. If you run into any further issues, please reach out to us at support@drip.com.
Posted Nov 13, 2019 - 09:40 CST
Update
We are continuing to investigate reports of issues with email sending specific to broadcast emails. Thank you for sticking with us on this. We don't have further information to share yet, but this is the top priority for our team right now and we are taking action to resolve this issue.
Posted Nov 13, 2019 - 09:14 CST
Investigating
We are experiencing issues sending broadcast emails. This issue is not impacting automation, campaign, or confirmation emails. Our team is investigating and we will update as soon as we have more information.
Posted Nov 13, 2019 - 08:41 CST
This incident affected: Email Sending.