Issues Contacting Support via Email
Incident Report for Drip
Resolved
We are happy to report that email support via the in-app widget is back up and running. We apologize for any inconveniences this caused and appreciate you sticking with us!
Posted Oct 31, 2019 - 12:57 CDT
Investigating
Our support ticketing tool is currently experiencing issues preventing customers from emailing us via our in-app support widget. We are working to get to a resolution. If you need assistance from our support team in the meantime, we are available on live chat via our in-app support widget or you can reach out to support@drip.com directly.
Posted Oct 31, 2019 - 12:38 CDT
This incident affected: Support Systems.