Single Email Campaign delays
Incident Report for Drip
Resolved
Thank you for your patience while we investigated this issue. Deliveries are now moving and the problem is resolved. Please reach out to support@drip.com with any further questions or concerns.
Posted Jun 16, 2023 - 10:00 CDT
Monitoring
We have identified a fix to Single Email delivery delays, and deliveries are catching up. We will continue to monitor the outcome and follow up with an update soon.
Posted Jun 16, 2023 - 09:39 CDT
Investigating
Drip is currently experiencing an issue with Single Email Campaign deliveries. This issue is not impacting automation, email series, or confirmation emails. Our team is investigating and we will provide an update as soon as we have more information.
Posted Jun 16, 2023 - 08:29 CDT
This incident affected: Email Sending.