Delays in email sending
Incident Report for Drip
Resolved
Our team resolved the delays in email sending. Emails scheduled during this incident are catching-up quickly. We appreciate your patience! If you experience any further issues please reach out to our Support team at support@drip.com.
Posted Nov 23, 2019 - 10:12 CST
Monitoring
A fix has been implemented for this issue and we are monitoring the results. We'll be back here with an update as soon as possible. Thank you for sticking with us!
Posted Nov 23, 2019 - 09:57 CST
Identified
We are currently experiencing delays in email sending. Our team has identified the issue and is working to resolve it as quickly as possible. We apologize for any inconvenience this is causing and we will update you here as soon as we have more information.
Posted Nov 23, 2019 - 09:26 CST
This incident affected: Email Sending.