Subscriber Profiles and Email Series Unable to Load
Incident Report for Drip
Resolved
We are happy to report that all systems have returned to normal. If you are still seeing issues with performance, please reach out to our support team via support@drip.com. Thank you for sticking with us!
Posted Sep 29, 2023 - 00:00 CDT
Identified
We've identified the root of the degradation and believe that an underlying issue with one of our upstream providers is causing delays as well as performance slowdowns. Until that issue has been resolved, we expect performance within Drip to continue to be impacted. Our team is continuing to investigate other solutions and will post additional updates as we have them.
Posted Sep 28, 2023 - 20:21 CDT
Investigating
Drip is currently experiencing some service interruptions that are impacting the ability to load subscriber profiles and email series lists. Our team is investigating and we will provide an update as soon as we have more information.
Posted Sep 28, 2023 - 15:58 CDT
This incident affected: REST and JavaScript APIs, User Interface, Email Sending, New People Adds, and Workflows and Rules.