Delays in email sending
Incident Report for Drip
Resolved
Our team has resolved the delays in email sending. We appreciate your patience today! If you experience any further issues please reach out to our Support team at support@drip.com.
Posted Nov 11, 2019 - 12:11 CST
Update
Our team is making progress tackling these sending delays, but we are not out of the woods yet. We will continue to update here with our progress. Thank you for your patience!
Posted Nov 11, 2019 - 11:41 CST
Identified
We have identified the root cause of the issue and our team is working quickly to get through these delays. At this time the delays are mainly impacting broadcast emails. We'll be back here with an update as soon as possible. Thank you for sticking with us today.
Posted Nov 11, 2019 - 11:08 CST
Investigating
We are experiencing delays sending emails. Our team is working quickly to decrease the impact of these delays. We will update you as soon as we have more information and apologize for any inconvenience this may cause.
Posted Nov 11, 2019 - 10:30 CST
This incident affected: Email Sending.