We are pleased to report that our service has been fully restored. Thank you for your patience and please contact our support team at support@drip.com if you have any additional questions.
Posted Feb 27, 2025 - 10:42 CST
Update
We are continuing to monitor for any further issues.
Posted Feb 27, 2025 - 09:48 CST
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Feb 27, 2025 - 09:44 CST
Investigating
We are currently experiencing elevated errors in the Drip application. Our development team is investigating the issue and will post an update as soon as we have more information.