Email Sends not reflected in Activity Timeline

Incident Report for Drip

Resolved

The team has confirmed all delivery events have been recovered and are displayed on affected profiles. Issue resolved.
Posted Aug 18, 2025 - 14:46 CDT

Monitoring

The team has identified and pushed out a fix to address the issue. Affected events are recovering, we're continuing to monitor.
Posted Aug 18, 2025 - 10:42 CDT

Investigating

We are currently investigating a UI issue where email send and receipt data is not appearing on profiles. This is also affecting segmentation for recipients, which may show as blank. Please note that despite this display issue, emails are still being successfully sent. We apologize for any inconvenience this may cause and will provide an update as soon as we have more information.
Posted Aug 18, 2025 - 10:37 CDT
This incident affected: User Interface and Email Sending.