Delays in email sending
Incident Report for Drip
Resolved
Our team identified the root cause of the issue and was able to resolve the delays in email sending. We appreciate your patience! If you experience any further issues please reach out to our Support team at support@drip.com.
Posted Nov 14, 2019 - 17:55 CST
Update
We are continuing our work to decrease the delays we're seeing to email deliveries. We are not out of the woods yet but will be back with another update as we make progress on this issue. Thank you for your patience and understanding in the meantime.
Posted Nov 14, 2019 - 17:22 CST
Investigating
We are experiencing delays sending emails right now. We are working quickly to decrease the impact of these delays and will post an update here as soon as we have more information.
Posted Nov 14, 2019 - 16:51 CST
This incident affected: Email Sending.