Issues with email sends
Incident Report for Drip
Resolved
We can confirm that this issue is now resolved. Thank you very much for your patience throughout this process. If you have any questions or concerns at all, please reach out to our support team via our in-app support widget or by emailing support@drip.com.
Posted Apr 14, 2020 - 11:54 CDT
Monitoring
A fix has been implemented and our team is closely monitoring the results. We appreciate your patience and we will be back here with an update as soon as we have new information.
Posted Apr 14, 2020 - 11:13 CDT
Identified
The issue has been identified and a fix is being implemented. Our team is working hard to resolve this issue and we thank you for sticking with us.
Posted Apr 14, 2020 - 10:46 CDT
Investigating
We are currently investigating reports from some customers experiencing unexpected email sends to small segments of people in their account. We understand the urgency of this issue and are working diligently to assess the situation. We will provide an update here as soon as possible and sincerely apologize for any inconvenience this is causing.
Posted Apr 14, 2020 - 10:13 CDT
This incident affected: Email Sending.