Email campaign sending delays

Incident Report for Drip

Resolved

This incident has been resolved.
Posted Jul 28, 2023 - 09:58 CDT

Identified

We have identified the root cause of the issue and are working on resolving the sending delays.
Posted Jul 28, 2023 - 09:52 CDT

Investigating

Drip is currently experiencing an issue with Email Campaign deliveries that are resulting in delivery delays. Our team is investigating and we will provide an update as soon as we have more information.
Posted Jul 28, 2023 - 09:33 CDT
This incident affected: Email Sending.