Delays in email sending
Incident Report for Drip
Resolved
We are happy to report our team has resolved this issue and emails are processing at expected speeds. Thank you for your patience while we worked to address this problem. Please reach out to our support team at support@drip.com if you have any additional questions or concerns.
Posted Sep 13, 2019 - 15:44 CDT
Update
We are continuing to work through these delays and our team is making progress. While we will keep you updated here as we have more information, please reach out to our support team at support@drip.com if you have any questions or concerns.
Posted Sep 13, 2019 - 15:25 CDT
Identified
We have isolated the cause of these sending delays and our team is working diligently to bring broadcast delivery times back to normal. Thank you for bearing with us as we continue to work through this issue.
Posted Sep 13, 2019 - 14:53 CDT
Investigating
We are experiencing reports of delays sending broadcast emails. Our team is investigating and we will update as soon as we have more information. We apologize for any inconvenience this has caused.
Posted Sep 13, 2019 - 14:20 CDT
This incident affected: Email Sending.