Delays in email sending
Incident Report for Drip
Resolved
We are happy to report that our team has resolved the delays in email sending. We appreciate your patience while we worked through this issue! If you have any questions or concerns, please reach out to our support team at support@drip.com.
Posted Oct 28, 2019 - 12:24 CDT
Update
We are continuing to make progress working through these sending delays, but we are not out of the woods yet. We'll be back here with an update as soon as possible. Thank you for sticking with us.
Posted Oct 28, 2019 - 12:05 CDT
Monitoring
We are experiencing reports of delays sending broadcast emails. Our team has identified the cause of these delays and is working hard to resolve this issue. We will update you as soon as we have more information, and apologize for any inconvenience this has caused.
Posted Oct 28, 2019 - 11:35 CDT
This incident affected: Email Sending.