Increased Loading Times

Incident Report for Drip

Resolved

We are happy to report that page loading issues have been successfully resolved. If you have any additional questions or concerns, please don't hesitate to reach out to us at support@drip.com. Thank you for your patience and we apologize for any inconvenience this caused.
Posted May 23, 2025 - 12:27 CDT

Investigating

We have received reports that some users are seeing longer-than-normal loading times when accessing some pages within the application. Our team is investigating, and updates will be provided as soon as they become available.
Posted May 23, 2025 - 11:36 CDT
This incident affected: User Interface.