Issues populating segments on People page
Incident Report for Drip
Resolved
We can confirm this issue has been resolved and segments are populating successfully. Thank you for sticking with us! We apologize again for the disruption and thank you for your patience.
Posted Apr 22, 2020 - 11:34 CDT
Investigating
We are currently investigating reports of issues populating segments on the People page. We will provide an update here as soon as we have more information. We apologize for any inconvenience this may be causing.
Posted Apr 22, 2020 - 10:51 CDT
This incident affected: User Interface.