Drip App Disruption

Incident Report for Drip

Resolved

The issue affecting the app disruption has been resolved. Normal operations have resumed. Please reach out to support@drip.com if you have any questions.
Posted Mar 02, 2026 - 11:39 CST

Investigating

We are currently experiencing elevated errors in the Drip application. Our development team is investigating the issue and will post an update as soon as we have more information.
Posted Mar 02, 2026 - 05:20 CST
This incident affected: REST and JavaScript APIs, User Interface, Email Sending, New People Adds, Workflows and Rules, and Support Systems.